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1. Введение 

Данное руководство призвано помочь Вам быстро начать работу с редактором WPL-

Soft. Оно не претендует на полноту освещения функциональных возможностей редактора, 

но вполне возможно, что приведенной в нем информации окажется вполне достаточно для 

решения Ваших повседневных задач. Тем не менее, мы настоятельно рекомендуем Вам 

после прочтения настоящего руководства ознакомиться так же и с документацией 

поставляемой разработчиками редактора. 

Для выполнения действий приведенных в руководстве необходимо иметь общее 

представление об оконном интерфейсе операционной системы Windows и умение 

выполнять элементарные операции над файлами. 
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2. Инсталляция редактора WPL-Soft. 

Загрузить установочный дистрибутив редактора WPL-Soft можно  из сети интернет 

по адресу:  

http://www.delta.com.tw/product/em/control/plc/download/software/WPL2.11.60.zip. 

Распакуйте загруженный файл в папку, предлагаемую по умолчанию, и запустите из 

нее файл setup.exe. Через некоторое время появится окно приветствия установщика (рис. 

2.1). 

 
Рис. 2.1. Окно установщика. 

Нажмите на клавишу Next, появится следующее окно (рис. 2.2). В нем необходимо 

ввести имя пользователя (User Name) и название Вашей организации (Organization). Затем 

вновь нажмите кнопку Next. 

В следующем окне Вы можете изменить инсталляционный путь приложения. Как 

правило, необходимости в этом нет, так что просто нажмите еще раз кнопку Next.  

Появится окно готовности к установке приложения (рис. 2.3). В нем еще раз в 

обобщенном виде будут перечислены основные параметры установки. Нажмите на кнопку 

Install для установки приложения или Cancel, чтобы прервать установку. Вы так же 

можете вернуться на один из предыдущих шагов, нажав на кнопку Back. 
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Рис. 2.2. Введите имя пользователя и название организации. 

 
Рис. 2.3. Окно готовности к установке. 

Процесс установки обычно длится около минуты. После его окончания появится 

окно завершения работы установщика (рис. 2.4). Нажмите на кнопку Finish.  

Приложение успешно установлено! 
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Рис. 2.4. Окно завершения работы установщика. 
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3. Знакомство с редактором. 

3.1. Окно редактора. 

Установщик создаст для Вас на Рабочем столе иконку быстрого запуска редактора 

WPL-Soft (рис. 3.1). 

 
Рис. 3.1. Иконка быстрого запуска WPL-Soft. 

Двойным щелчком мыши по иконке WPL-Soft запустите редактор WPL-Soft. 

Появится окно редактора (рис. 3.2). 

В верхней части окна расположено главное меню приложения, чуть ниже – панель 

кнопок быстрого запуска. Серым отмечены неактивные кнопки и пункты меню. Они 

будут активированы только после создания или открытия проекта. 

Рабочая область окна разделена на две части. Слева расположено окно 

коммуникации, оно нам пока не понадобится. Справа – пока пустая серая область, в ней 

после создания проекта появятся окна редактирования логики проекта. 

 
Рис. 3.2. Окно редактора WPL-Soft. 
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3.2. Создание нового проекта. Окна редактирования логики проекта. 

Чтобы создать новый проект выберите пункт меню File → New ( ). Появится окно 

конфигурирования проекта (рис. 3.3). 

 
Рис. 3.3. Окно конфигурирования проекта. 

В верхней части окна Вы можете задать название проекта (Program Title).  Чуть 

ниже, расположена конфигурация PLC (оставьте настройки по умолчанию). В самом низу 

– область ввода имени файла проекта, его стоит изменить, задав более-менее осмысленное 

значение (например, Demo). 

Нажмите кнопку ОК. Появятся три окна, каждое из которых по-своему отражает 

логику созданного проекта: 

 Instruction List Mode (рис. 3.4) – отображает логику проекта в виде 

последовательности инструкций контроллера. Если Вы привыкли 

программировать логику в текстовом режиме, для вас это окно может 

оказаться полезным. Всем остальным заглядывать в него понадобится крайне 

редко. 
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Рис. 3.4. Окно Instruction List Mode. 

 Ladder Diagram Mode – отображает логику проекта в виде лестничных 

диаграмм. Это окно мы рекомендуем использовать в качестве основного окна 

редактирования. Примеры, рассмотренные в данном руководстве, будут 

использовать именно в это окно. 

 SFC Mode – отображает логику проекта в виде графов переходов. Если для 

Вас этот метод отображения более привычен, используйте его. Однако в 

данном руководстве редактирование в этом режиме не рассматривается. 

Обратите внимание, что нижняя часть панели кнопок быстрого запуска изменяется в 

зависимости от выбранного Вами окна отображения. Эта часть панели содержит кнопки 

редактирования логики проекта, они будут рассмотрены нами на соответствующих этапах 

создания логики демонстрационного проекта. 

Любое выбранное отображение логики может быть преобразовано в набор 

инструкций (Instruction List Mode). В свою очередь набор инструкций может быть 

преобразован в любой другой тип отображения. Все эти операции осуществляются 

вызовом команд меню Compiler (в скобках показана кнопка быстрого запуска команды): 

 Ladder => Instruction ( ) – преобразует лестничные диаграммы в набор 

инструкций. 

 Instruction => Ladder ( ) – преобразует набор инструкций в лестничные 

диаграммы 

 SFC => Instruction ( ) – преобразует граф переходов в набор инструкций 

 Instruction => SFC ( ) – преобразует набор инструкций в граф переходов. 

 

 



10 

 

 

3.3. Сохранение проекта 

Чтобы сохранить созданный Вами проект выберете пункт меню File → Save ( ). 

Появится стандартное диалоговое окно сохранения файла системы Windows. Задайте имя 

файла, которое считаете нужным или оставьте предлагаемое редактором по умолчанию и 

нажмите кнопку Сохранить. Проект будет сохранен в указанном Вами месте. 

3.4. Закрытие проекта. Выход из редактора. 

Чтобы закрыть проект выберете пункт меню File → Close Project. 

Чтобы выйти из приложения выберете пункт меню File → Exit или нажмите «Alt+X» 

с клавиатуры. 
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4. Демонстрационный проект 

Для знакомства с основными инструментами редактирования логики, 

предоставляемыми редактором WPL-Soft рассмотрим создание простого 

демонстрационного проекта.  

Этапы создания демонстрационного проекта Вы сможете в дальнейшем 

использовать в качестве краткого руководства по реализации того или иного элемента 

разрабатываемой Вами логики. 

4.1. Открытие созданного ранее проекта 

Для открытия созданного ранее проекта выберете пункт меню File → Open ( ). 

Появится стандартное диалоговое окно открытия файла системы Windows. В этом окне 

выберете имя файла проекта, сохраненного Вами на одном из предыдущих этапов и 

нажмите кнопку Открыть. 

Как и в случае создания нового проекта, после открытия сохраненного проекта 

неактивные кнопки быстрого запуска и пункты меню станут активными, а в правой части 

рабочей области появится окна редактирования логики проекта. 

Так как ранее в этом проекте мы не создавали никакой логики все окна, кроме окна 

редактирования набора инструкций, будут пустыми. По умолчанию вся память PLC 

заполнена командами NOP (no operation)  – нет операции. 

4.2. Создание простой логики 

Начнем с простого примера. Пусть входы 0 и 1 должны зажигать выход 0, а вход 2 

управлять работой схемы: если вход 2 установлен, выход 0 всегда выключен. Такая логика 

описывается следующей простейшей формулой: 

푦 = (푥 + 푥 ) ∙ 푥 ,                                                        (1) 

где x0…x2 – входы 0…2, соответственно; y0 – выход 0. 

Реализуем это логику на языке лестничных диаграмм. Для этого активируйте окно 

редактирования лестничных диаграмм, выбрав пункт меню View → Ladder Diagram ( ). 

Все лестничные диаграммы «растут» слева на право. Левая граница лестничной 

диаграммы отмечена вертикальной чертой.  

Окно редактирования лестничных диаграмм разбито на клетки, в каждой из таких 

клеток может быть размещено не более одного элемента лестничной диаграммы. Синий 

квадрат представляет собой область ввода. Перемещать область ввода можно с 

клавиатуры клавишами «вверх», «вниз», «влево», «вправо» или мышкой щелкая по 

интересующей Вас части лестничной диаграммы. 
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Установите область ввода в левый верхний угол лестничной диаграммы, как 

показано на рисунке 4.1. 

 
Рис. 4.1. Исходное положение области ввода 

Выбор команд редактирования осуществляется нажатием на соответствующие 

кнопки панели быстрого запуска. Кроме того все команды редактирования имеют горячие 

клавиши (они изображены на нижней части кнопок редактирования). 

Входы и маркеры на лестничной диаграмме представлены в виде контактов 

различного типа. Всего существует четыре типа контактов, каждому из которых 

соответствует кнопка панели быстрого запуска: 

 Нормально разомкнутый контакт ( ).  

 Нормально замкнутый контакт ( ) 

 Контакт, замыкаемый фронтом сигнала ( )  

 Контакт, замыкаемый спадом сигнала ( ). 

Нажмите на кнопку  панели быстрого запуска или кнопку «F1» клавиатуры. 

Появится окно редактирования устройства (рис. 4.2). 

 
Рис. 4.2. Окно редактирования устройства. 

В левом верхнем углу окна указан тип редактируемого устройства – нормально 

разомкнутый контакт (Constantly opened contact). 
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В окне редактирования устройства необходимо указать тип (имя) устройства (Device 

Name) и номер устройства (Device Number).  

В редакторе WPL-Soft существуют следующие типы (имена) устройств: 

 X – входы 

 Y – выходы 

 M(S) – маркеры 

 T – таймеры 

 C – счетчики 

Диапазон доступных номеров устройств указан красными буквами рядом с 

надписью Range. При этом входы и выходы нумеруются в восьмеричной системе, а 

маркеры, таймеры и счетчики – в десятичной. 

Поле Comment позволяет задать комментарий к устройству. Комментарии сделают 

Вашу лестничную диаграмму более понятной и простой для восприятия. 

Итак, задайте имя устройства X, номер – 0, в поле комментария (Comment) введите 

«Вход 0». После этого нажмите кнопку ОК. 

Сместите поле ввода вниз и проделайте все тоже самое для устройства X1. В поле 

комментария введите «Вход 1» 

В результате у Вас должно получиться что-то подобное рисунку 4.3. 

 
Рис. 4.3. Входы 0 и 1 на лестничной диаграмме. 

Так как оба входа 0 и 1 должны зажигать выход 0, нам необходимо объединить X0 с 

X1. Поместите поле ввода справа от X0 и нажмите на кнопку  («F9» с клавиатуры), 

появится вертикальная черта, соединяющая X0 с X1. 

Выходы на лестничных диаграммах отображаются в виде катушек (Coils). В 

отличие от контактов, катушка на лестничной диаграмме всегда находится в крайнем 

правом положении. Катушка устанавливает состояние соответствующего ей устройства 

как результат работы участка диаграммы (последовательности контактов) слева от нее. 
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Помимо выходов (Y) катушками могут быть маркеры (M, S), это позволяет сохранять 

результаты работы участков диаграммы и использовать их на следующих циклах работы 

PLC. 

Добавьте на диаграмму выход 0. Для этого нажмите на кнопку  («F7» с 

клавиатуры). Появится окно редактирования устройства (рис. 4.2). В левом верхнем углу, 

как обычно, указан тип редактируемого устройства – выходная катушка (Output Coil). 

Задайте имя устройства – Y, номер устройства – 0, комментарий – «Выход 0» и нажмите 

ОК. 

Катушка появится не в выбранной Вами области ввода, как Вы можете ожидать, а в 

крайнем правом положении на лестничной диаграмме, где она и должна находиться по 

правилам. В результате у вас должно получиться что-то подобное рисунку 4.4. 

 
Рис. 4.4. Входы 0, 1 и выход 0 на лестничной диаграмме. 

Осталось добавить вход 2. В соответствии с формулой (1) вход 2 должен быть 

нормально замкнутым реле. Поместите область ввода справа от X0 и нажмите на кнопку 

 («F2» с клавиатуры). Вновь появится окно редактирования устройства (рис. 4.2),  

типом устройства на этот раз будет нормально замкнутый контакт (constantly closed 

contact). Введите имя и номер устройства (X2) и задайте комментарий («Вход 2»). 

В итоге у Вас должна получиться следующая картинка: 

 
Рис. 4.5. Входы 1..3, выход 0 на лестничной диаграмме. 

4.3. Работа с таймерами и счетчиками. 

Теперь перейдем к устройствам чуть более сложным, чем катушки и контакты – к 

таймерам. Таймеры служат для введения задержки распространения сигналов. 

Длительность задержки устанавливается в периодах работы PLC (10 мс для ЛИР-986). У 

каждого таймера есть вход и выход. Вход таймера управляет работой таймера, а выход 

отражает его текущее состояние.  
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При наличии положительного сигнала на входе таймера, таймер начинает работать. 

Как только сигнал пропадает, таймер сбрасывается. По достижению таймером 

установленного значения задержки, включается выход таймера.  

 

 

В лестничных диаграммах работой таймеров управляют специальные инструкции. 

Инструкции могут управлять не только таймерами, во многом они похожи на катушки: 

они так же располагаются в крайнем правом положении на диаграмме и используют в 

качестве условия активации результат работы последовательности контактов слева. Но 

операции выполняемые инструкциями значительно более сложные, чем простое 

включение/выключение некоторого устройства, к тому же, инструкции могут принимать 

конфигурирующие их работу параметры. 

Добавим задержку на установку выхода 0. Для этого поместите область ввода справа 

от контакта X2 и нажмите на кнопку  («F6» с клавиатуры). Появится окно 

редактирования инструкций (рис. 4.6).  

 
Рис. 4.6. Окно редактирования инструкций. 

В списке Instruction Type (Тип Инструкции) выберите Timer & Counter (Таймер и 

Счетчик). В списке Application Instruction выберите TMR. Окно приобретет вид, 

представленный на рисунке 4.7, появятся параметры S и D, а также Reference (справка) 

внизу окна. 

Справка состоит из двух окон. В верхнем окне звездочками отмечены допустимые 

для каждого из параметров типы (имена) устройств. В нижнем окне размещена 
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справочная информация по каждому из параметров: S – Timer number (номер таймера), D – 

Timer Setting Value (значение задержки таймера). 

Выберете из списка параметра S значение T, затем в появившемся числовом поле 

ввода задайте номер таймера – 0. Затем аналогично для параметра D – тип устройства «K» 

(константа), значение 100 (задержка на 1 с) и нажмите ОК. 

Катушка Y0 заменится символом таймера 0. В этом символе указано слева на право: 

имя инструкции конфигурирующей таймер (TMR), имя таймера (T0) и величина задержки 

таймера (K100 – константа 100). 

Теперь, чтобы таймер 0 устанавливал выход 0 нужно добавить на диаграмму выход 

таймера и выход 0. Выход таймера добавьте в виде нормально разомкнутого контакта, а 

выход 0, как и прежде, в виде катушки. Обратите внимание на то, что редактор WPL-Soft 

запомнил комментарий к устройству Y0 («Выход 0»). Проделайте это самостоятельно, 

результат, который у Вас должен получиться, представлен на рисунке 4.8. 

 

 

 
Рис. 4.7. Окно редактирования инструкций после выбора инструкции. 
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Рис. 4.8. Результат добавления таймера 0. 

Счетчики предназначены для подсчета импульсов. Так же как и таймеры, счетчики 

имеют собственный вход и выход. Счет импульсов осуществляется по входу счетчика. 

Как только значение счетчика достигает заданного значения, счетчик устанавливает свой 

выход в активное состояние.  

Добавим счетчик импульсов по входам X0, X1. Для этого установите область ввода 

справа от X1 и нажмите на кнопку  («F6» с клавиатуры). В появившемся окне 

редактирования инструкций (рис. 4.6) выберите Instruction Type (Тип Инструкции) - Timer 

& Counter (Таймер и Счетчик), Application Instruction – CNT. Окно изменится подобно 

тому, как это было при добавлении таймера. Задайте следующие параметры: S – C1 (в 

ЛИР-986 таймеры и счетчики это одни и те же устройства, поэтому следите чтобы номера 

устройств C и T в Ваших проектах не совпадали), D – K10. 

Выход счетчика 1 отправим так же на выход 0. Для этого добавьте нормально 

разомкнутый контакт C1 и катушку Y0. Задайте комментарий к контакту C1 – «Счетчик 

импульсов».  

Сброс счетчика осуществляется инструкцией RST.  

Установим сброс счетчика 1 по установке выхода таймера 0. Для этого установите 

область ввода справа от контакта T0 и нажмите на кнопку  («F6» с клавиатуры). В 

появившемся окне редактирования инструкций (рис. 4.6) выберите Instruction Type (Тип 

Инструкции) - Output (Выход), Application Instruction – RST. Единственный появившийся 

параметр S установите равным С1 и нажмите OK. 

Теперь можно добавить осмысленный комментарий к контакту T0. Для этого 

щелкните дважды мышью по контакту T0 или, установив на него область ввода, нажмите 

клавишу «Enter» с клавиатуры. Появится окно Input Instruction (ввод инструкции), в нем 

нажмите на кнопку «…» чтобы вызвать окно редактирования устройства (рис. 4.2). 

Введите комментарий «Сброс счетчика импульсов» и нажмете ОК. 

Результат добавления счетчика представлен на рисунке 4.9. 
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Рис. 4.9. Результат добавления счетчика 1. 

4.4. Добавление RS-триггера 

Инструкции SET и RST позволяют создавать RS-триггер. Инструкция SET 

устанавливает устройство в активное состояние, а RST – сбрасывает. 

Пусть импульс по входу 3 устанавливает выход 3, а импульс по входу 4 – его 

сбрасывает. 

Установите область ввода под контактом C1 и нажмите на кнопку  («F3» с 

клавиатуры). Появится окно редактирования устройства (рис. 4.2). Тип устройства – 

Rising-edge Contact (Контакт, замыкаемый фронтом сигнала). Введите имя устройства – X, 

номер – 3, комментарий – «S». Сместите область ввода вниз и добавьте аналогичный 

контакт X4 с комментарием «R». 

Теперь поместите область ввода справа от X3 и нажмите на кнопку  («F6» с 

клавиатуры). В появившемся окне редактирования инструкций (рис. 4.6) выберите 

Instruction Type (Тип Инструкции) - Output (Выход), Application Instruction – SET. 

Параметр S установите равным Y3 и нажмите OK.  

Поместите область ввода справа от X4 и добавьте инструкцию RST, параметр S 

установите равным Y3. Результаты редактирования показаны на рисунке 4.10. 

 
Рис. 4.10. Результат добавления RS-триггера на выход 1. 
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4.5. Импульсные выходы. Добавление пустых строк. 

Допустим, нам нужно генерировать один короткий импульс на выход 1 при наличии 

высокого уровня на входах 0 или 1 (например, при нажатии на кнопку). Для этих целей 

можно использовать импульсные инструкции: 

 PLS – генерирует один импульс в целевом устройстве (маркер или выход) при 

появлении высокого уровня на входе. 

 PLF – генерирует один импульс в целевом устройстве (маркер или выход) 

при появлении низкого уровня на входе. 

Инструкции PLS/PLF добавляются аналогично инструкциям SET/RST, разница 

заключается только в выборе параметра Application Instruction – его необходимо задать в 

соответствии с требующейся инструкцией (либо PLS, либо PLF). 

Установите область ввода справа от X1, нажмите на кнопку  («F6» с клавиатуры) 

и добавьте инструкцию PLS. Параметр D установите равным Y1. 

Считать импульсы счетчик 1 теперь может по выходу 1, причем делать это он 

должен до инструкции сброса, иначе в случае короткого импульса на входах 0,1 сброс 

счетчика может не сработать. Для этого необходимо вставить пустую строку перед 

инструкцией сброса. 

Установите поле ввода на контакт T0 и выберите пункт меню Edit → Insert Row. 

Появится нужная нам пустая строка. Теперь добавьте нормально разомкнутый контакт Y1 

и инструкцию конфигурации счетчика C1. Задайте комментарий «Импульсный выход 1» 

для Y1, счетчик сконфигурируйте, как и прежде, на 10 импульсов.  

Добавим еще один импульсный выход, который будет генерировать короткий 

импульс при срабатывании таймера 0.  

Сделаем таким выходом выход 2. Для этого добавьте пустую строку выше контакта 

C1, затем установите поле ввода справа от контакта T0 и нажмите на кнопку  («F9» с 

клавиатуры), чтобы добавить вертикальную черту. Теперь переместите поле ввода на одно 

деление вниз и добавьте инструкцию PLS для выхода 2. 

Результат добавления импульсных выходов представлен на рисунке 4.11. 
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Рис. 4.11. Результат добавления импульсных выходов. 

4.6. Отключаемые блоки на лестничной диаграмме 

Включение/выключение отключаемых блоков лестничной диаграммы 

осуществляется инструкциями MC/MCR, при этом границы отключаемого блока задают 

сами инструкции: MC начинает блок, а MCR его заканчивает. 

Инструкция MC принимает на входе условие включения блока. Если уровень 

сигнала на входе высокий, блок будет включен, если низкий – выключен. 

Сделаем выключаемым блок лестничной диаграммы, отвечающий за обработку 

входов 1 и 2. Функционально он никак не связан с последующей частью диаграммы, 

поэтому его отключение будет вполне корректным. Работой отключаемого блока будет 

управлять вход 0. 

Добавьте пустые строки над контактами X0 и X3 (на границах отключаемого блока). 

Переместите область ввода на контакт X0 и нажмите на кнопку «Delete» клавиатуры. 

Контакт будет удален с диаграммы. Теперь снова добавьте нормально разомкнутый 

контакт X0, но уже в верхнюю пустую строку. Справа от него добавьте инструкцию MC. 

Для этого нажмите на кнопку  («F6» с клавиатуры), в появившемся окне 

редактирования инструкций выберите из списка Application Instruction инструкцию MC. 

Единственный параметр N (номер слоя) установите равным 0 и нажмите OK. 

Аналогичным образом добавьте инструкцию MCR в нижнюю пустую строку. 

Теперь для того чтобы активировать блок, обрабатывающий входы 1,2 необходимо 

подать высокий уровень на вход 0. Это может оказаться не очень удобным, так как блок 

будет нормально выключенным. Чтобы сделать его нормально включенным необходимо 

заменить нормально разомкнутый контакт X0 на нормально замкнутый.  
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Переместите область ввода на контакт X0 и в нижнем левом углу панели быстрого 

запуска из списка типов контактов (рис. 4.12) выберите нормально замкнутый контакт. 

 
Рис. 4.12. Список типов контактов (реле). 

Итоговая лестничная диаграмма представлена на рисунке 4.13. 

 
4.13. Добавление отключаемого блока. 

Имейте в виду, что при отключении блока лестничной диаграммы вся входящая в 

блок логика будет игнорироваться PLC. Это приведет к тому, что состояние всех 

устройств, входящих в блок, в частности выходов, будет оставаться неизменным до 

нового включения блока. В связи с этим не следует ожидать, что при выключении 

выделенного нами блока выходы 0, 1 и 2 погаснут, напротив, выходы сохранят свое 

состояние до включения блока. 

4.7. Инверсия. Логический элемент ИЛИ-НЕ 

Создадим логический элемент ИЛИ-НЕ для входов 5,6 и выхода 4. Для этого 

добавьте на диаграмму два нормально разомкнутых контакта X5 и X6 один под другим. 

Задайте комментарии «A» и «B», соответственно. Затем поместите область ввода справа 
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от контакта X5 и нажмите на кнопку  («F9» с клавиатуры). Контакты X5 и X6 

соединятся вертикальной чертой. Теперь, не перемещая область ввода, добавьте катушку 

Y4. 

Мы создали элемент ИЛИ, осталось добавить инверсию, для этого нажмите на 

кнопку  («F11» с клавиатуры). Косая черта означает инверсию участка лестничной 

диаграммы находящейся левее черты. Дважды щелкнув по катушке Y4, задайте 

комментарий к устройству – «NOR». 

Лестничная диаграмма элемента ИЛИ-НЕ представлена на рисунке 4.14. 

 
Рис. 4.14. Лестничная диаграмма элемента ИЛИ-НЕ. 

4.8. Кнопки редактирования вертикальных соединений. 

Редактирование вертикальных соединений подразумевает выполнение двух 

операций: создание соединений и их удаление. При выполнении обеих этих операций 

область ввода должна располагаться над соединением, как показано на рисунке 4.15. 

 
Рис. 4.15. Положение области ввода при редактировании вертикальных соединений 

Мы уже неоднократно использовали кнопку  для создания вертикальных 

соединений. Для удаления таких соединений используйте кнопку  или «Ctrl+D» с 

клавиатуры. Имейте ввиду, что вертикальные соединения, в отличие от горизонтальных 

не удаляются кнопкой «Delete». 

Следующие кнопки удобно использовать для последовательного редактирования 

нескольких вертикальных соединений: 

 Кнопка  («Alt+F9» с клавиатуры) создает вертикальное соединение и 

смещает область ввода на одно деление вниз. 

 Кнопка  («Alt+D» с клавиатуры) удаляет вертикальное соединение и 

смещает область ввода на одно деление вниз. 
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4.9. Отображение комментариев и вывод диаграммы на печать. 

Редактируя демонстрационный проект, мы постоянно создавали комментарии к 

добавляемым устройствам. Однако эти комментарии никак не отображались на 

диаграмме. И это хорошо, так как при редактировании диаграммы комментарии нам бы 

только мешали, загромождая область редактирования. Теперь же, когда 

демонстрационный проект полностью завершен, комментарии можно показать. Для этого 

выберите пункт меню View → Show Comments. 

 
Рис. 4.16. Окно редактирования комментариев 

Вы можете заметить, что, несмотря на все наши старания, далеко не все выходы 

имеют комментарии. Дело в том, что мы прописывали комментарии к устройствам только 

при создании контактов и катушек. При добавлении инструкций возможности добавить 

комментарии нам не представилось. Чтобы добавить недостающие комментарии вызовите 

пункт меню View → Edit Device Comments. Появится окно редактирования комментариев. 

Нажмите на кнопку Y, окно должно приобрести вид, показанный на рисунке 4.16. 

Звездочками слева отмечены используемые в проекте устройства. 

Добавьте следующие комментарии к устройствам: 

 Y2 – Импульсный выход 2 

 Y3 – RS-триггер 
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Перейдите к окну редактирования лестничных диаграмм, для этого щелкните по 

нему мышью или выберите пункт меню View → Ladder Diagram ( ). Диаграмма должна 

принять вид, показанный на рисунке 4.17. 

 
4.17. Итоговая лестничная диаграмма 

Чтобы вывести эту диаграмму на печать выберите пункт меню File → Print ( ). 

Появится диалоговое окно настройки параметров печати (рис. 4.18). 
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Рис. 4.18. Диалоговое окно настройки параметров печати. 

Поле Print Options (Параметры печати) содержит переключатель позволяющий 

выбирать, что именно будет выведено на печать. В положении переключателя All на 

печать будет выведена вся лестничная диаграмма, в положении Part – только страницы 

заданные границами Start (начало) и End (конец). 

Поле Margin позволяет задать поля документа: 

 Top – верхнее; 

 Bottom – нижнее; 

 Left – левое; 

 Right – правое. 

В левом нижнем углу расположены флажки позволяющие задать дополнительные 

информационные элементы, выводимые на печать: 

 Title – название проекта; 

 Page Number – номер страницы; 

 Cover – переплет; 

 Frame – рамка. 

Кнопка Print Setup вызывает стандартное окно настройки принтера. 

Кнопка Preview запускает программу предварительного просмотра документа перед 

печатью.  

Нажмите на кнопку Cancel, если не собираетесь ничего печатать. 
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4.10. Компиляция проекта. 

Итак, мы полностью нарисовали лестничную диаграмму логики нашего проекта, 

однако если Вы сейчас перейдете к окну отображения набора инструкций, вызвав пункт 

меню View → Instruction List, то обнаружите, что его содержимое по-прежнему никак не 

изменилось. 

Чтобы перевести лестничную диаграмму в набор инструкций, необходимо 

скомпилировать проект. Это обязательная операция, без нее вся созданная Вами логика – 

это не более чем картинка. 

За компиляцию проекта отвечает раздел меню Compiler (Компилятор). Он содержит 

различные варианты преобразования отображений логики в набор инструкций и обратно 

(см. пункт 3.2). Нам понадобится пункт меню Ladder => Instruction. Если у Вас все еще 

активно окно отображения набора инструкций, то этот пункт меню будет неактивным 

(серым). Перейдете к окну редактирования лестничных диаграмм и вызовите 

требующийся пункт меню. 

В процессе компиляции появится ошибка. Информация об этом будет в возникшем 

снизу окне (рис. 4.19). 

 
Рис. 4.19. Ошибка компиляции. 

Поле ввода будет переведено в ту область диаграммы, где обнаружена ошибка. В 

нашем случае это вторая строка. Действительно в этом месте диаграмма формально 

неверна, исправьте ее как показано на рисунке 4.20 и повторите процесс компиляции. 

 
Рис. 4.20. Исправленный участок лестничной диаграммы. 
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На этот раз все должно быть в порядке, через некоторое время появится 

всплывающее окно, радостно информирующее Вас об окончании процесса компиляции, 

чтобы убрать его нажмите кнопку OK. 

Обратите внимания, что на диаграмме слева появились синие числа, это номера 

инструкций, начинающих очередную ветвь диаграммы (как правило, это разновидность 

инструкции LD). 

Теперь вернитесь обратно к окну отображения набора инструкций, оно должно 

выглядеть как на рисунке 4.21. 

 
Рис. 4.21. Набор инструкций демонстрационного проекта. 

Синей полоской отмечена инструкция, выделенная в окне редактирования 

лестничных диаграмм. 

На этом создание демонстрационного проекта завершено. Сохраните его в удобном 

для Вас месте, закройте проект и выйдете из редактора WPL-Soft. 
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5. Отладка проекта 

Данный раздел будет посвящен не редактору WPL-Soft, а тому, как можно проверить 

работоспособность созданного в WPL-Soft проекта при помощи средств 

программирования и отладки VMTools. 

Для удобства будем считать, что демонстрационный проект сохранен в папке 

C:\Projects под именем Demo.dvp, а средства программирования и отладки успешно 

сконфигурированы и находятся в папке C:\vmtools. 

5.1. Транляция проектного файла WPL-Soft. 

Для проверки работоспособности созданного нами демонстрационного проекта его 

необходимо загрузить в программный эмулятор VMTools. Эту операцию осуществляет 

bat-файл emudvp.bat. Вызовите Пуск → Выполнить, в появившемся окне наберите 

команду:  

C:\vmtools\emudvp.bat C:\Projects\Demo.dvp 

Появится окно консоли (рис. 5.1). Следуйте появляющимся в консоли указаниям. 

Если проект создан правильно, никаких ошибок возникнуть не должно. После завершения 

последней операции окно самостоятельно закроется. 

 
Рис. 5.1. Окно консоли. 

Теперь, когда проектный файл успешно загружен в программный эмулятор, можно 

перейти к эмуляции проекта. 
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5.2. Эмуляция логики проекта 

Дважды щелкните на иконке «Отладчик виртуальной машины» на Рабочем Столе. 

Появится окно отладчика (рис. 5.2). 

 
Рис. 5.2. Окно программы «Отладчик виртуальной машины». 

Установите галочку Режим эмуляции, после чего задайте требующееся число 

входов, выходов и таймеров (все по 12) и нажмите на кнопку Подключиться. 

Появятся окна входов и выходов (рис. 5.3). 
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Рис. 5.3. Окна входов и выходов 

Каждый кружочек соответствует, в зависимости от окна, входу или выходу. Флажки 

под входами в окне входов позволяют выбирать, будет ли вход управляться с ПК или 

работать самостоятельно. Последнее актуально для отладки логики контроллера ЛИР-986, 

для эмулятора такой режим бесполезен, поэтому в режиме эмуляции все флажки по 

умолчанию установлены. 

Нажмите на кнопку Старт, чтобы начать выполнение эмулятором загруженного 

нами проекта. Кликните мышкой по кружку под цифрой 1 – это первый вход. Кружок 

станет зеленым, а в области таймеров в строке 0 начнут «бежать» цифры. Число в строке 1 

увеличится на 1 (рис. 5.4). 

 
Рис. 5.4. Изменения в области таймеров. 

Это говорит о том, что при включении входа 1 запустился таймер 0, а счетчик 1 

зафиксировал 1 импульс. Если Вы немного подождете, то увидите, что таймер 0 досчитает 

до 100 и сбросит значение счетчика 1. При этом моргнет красным выход 2. Все это вполне 

соответствует логике проекта. 

Еще раз щелкните мышкой по входу 1, таймер 0 обнулится, а вход погаснет.  

Щелкните несколько раз по входу 1, генерируя непродолжительные импульсы. 

Каждый раз значение счетчика 1 будет увеличиваться на 1. Когда оно достигнет 10, 

установится выход 0. Если вы оставите на время вход 1 включенным, счетчик 1 сбросится 

вместе с выходом 0. 

Теперь включите вход 0 и попробуйте проделать то же самое. Вы сразу заметите, что 

таймер и счетчик никак не реагируют на включение/выключение входа 1. Так и должно 

быть, ведь мы отключили блок логики, отвечающий за обработку состояния этого входа. 

Проверьте самостоятельно работу RS-триггера и элемента ИЛИ-НЕ. 

Если в какой-то момент Вам понадобится сбросить состояние виртуальной машины 

– нажмите на кнопку Сброс. 

Чтобы остановить работу эмулятора нажмите на кнопку Стоп. 

Установите флаг Однократно если Вы хотите контролировать состояние эмулятора 

дискретно на каждом цикле виртуальной машины. 

 


